Différences

Ci-dessous, les différences entre deux révisions de la page.

Lien vers cette vue comparative

Les deux révisions précédentes Révision précédente
Prochaine révision
Révision précédente
lamp [Le 13/07/2018, 09:00]
krodelabestiole déplacement [Conflits potentiels entre plusieurs versions de PHP] vers page PHP
lamp [Le 14/02/2019, 00:09] (Version actuelle)
Flens [Création d'une base de donnée et d'un utilisateur associé]
Ligne 6: Ligne 6:
  
   * **Linux** : le système d'​exploitation,​ on peut déployer la pile LAMP sur la plupart des distributions GNU/Linux ;   * **Linux** : le système d'​exploitation,​ on peut déployer la pile LAMP sur la plupart des distributions GNU/Linux ;
-  * **[[:​Apache]]** : le serveur HTTP, il permet au serveur de communiquer avec le navigateur en utilisant le protocole HTTP(S) ;+  * **[[:apache2|Apache]]** : le serveur HTTP, il permet au serveur de communiquer avec le navigateur en utilisant le protocole HTTP(S) ;
   * **MySQL** : il s'agit d'un serveur de bases de données. Il sert à stocker, à manipuler ​ et à accéder à des listes de données organisées en tableaux. Ce service peut être fournit par le logiciel [[:MySQL]] ou par [[:​MariaDB]] (fork plus ouvert, plus performant, et 100% compatible MySQL).   * **MySQL** : il s'agit d'un serveur de bases de données. Il sert à stocker, à manipuler ​ et à accéder à des listes de données organisées en tableaux. Ce service peut être fournit par le logiciel [[:MySQL]] ou par [[:​MariaDB]] (fork plus ouvert, plus performant, et 100% compatible MySQL).
   * **[[:​PHP]]** : PHP est un langage de programmation interprété qui permet de générer du contenu web dynamiquement. Il s'agit la plupart du temps de pages [[wpfr>​HTML]]).   * **[[:​PHP]]** : PHP est un langage de programmation interprété qui permet de générer du contenu web dynamiquement. Il s'agit la plupart du temps de pages [[wpfr>​HTML]]).
Ligne 20: Ligne 20:
 Cette méthode consiste à [[:​tutoriel:​comment_installer_un_paquet|installer]] les paquets nécessaires pour Apache, PHP et MySQL :\\ Cette méthode consiste à [[:​tutoriel:​comment_installer_un_paquet|installer]] les paquets nécessaires pour Apache, PHP et MySQL :\\
  
-<code bash>​sudo apt install libapache2-mod-php mysql-server php-mysql</​code>​+<code bash>​sudo apt install ​apache2 php libapache2-mod-php mysql-server php-mysql</​code>​
 ou si vous préférez opter pour [[:​mariadb|MariaDB]] au lieu de MySQL : ou si vous préférez opter pour [[:​mariadb|MariaDB]] au lieu de MySQL :
-<code bash>​sudo apt install libapache2-mod-php mariadb-server php-mysql</​code>​+<code bash>​sudo apt install ​apache2 php libapache2-mod-php mariadb-server php-mysql</​code>​
  
 +(attention le paquet php installe directement la dernière version de php)
  
 La pile LAMP est alors installée. Cependant la plupart des scripts [[:PHP]] ([[:CMS]], forums, applications web en tout genre) utilisent des [[php#​modules|modules de PHP]] pour bénéficier de certaines fonctionnalités.\\ La pile LAMP est alors installée. Cependant la plupart des scripts [[:PHP]] ([[:CMS]], forums, applications web en tout genre) utilisent des [[php#​modules|modules de PHP]] pour bénéficier de certaines fonctionnalités.\\
Ligne 117: Ligne 118:
 sudo systemctl reload apache2</​code>​ sudo systemctl reload apache2</​code>​
  
-Pour plus de détails, consultez la documentation //​[[:​apache2#​creation_d_hotes_virtuels|création ​d'​hôtes virtuels]]//​.+<note tip>Pour plus de détails, consultez la documentation //​[[:​apache2#​creation_d_hotes_virtuels|Création ​d'​hôtes virtuels]]//, et pour des exemples pratiques consultez le tutoriel //​[[:​tutoriel:​lamp_repertoires_de_travail|Créer un/des répertoires de travail]]//.</​note>​
  
 ==== Création d'une base de donnée et d'un utilisateur associé ==== ==== Création d'une base de donnée et d'un utilisateur associé ====
Ligne 167: Ligne 168:
 Upgrade process encountered error and will not continue.</​code>​ Upgrade process encountered error and will not continue.</​code>​
  
-Dans ce cas il faut supprimer les paquets ainsi que tous les fichiers de configuration de votre serveur de bases de données. Attention cela rendra les bases de données existantes inaccessibles ! +Dans ce cas le plus simple est de supprimer les paquets ainsi que tous les fichiers de configuration de votre serveur de bases de données ​en [[:mysql#​reinstallation_complete|réinstallant complètement ​MySQL ou MariaDB]].
- +
-<​code>​sudo apt autoremove --purge mysql-server\* mariadb-server\* +
-sudo mv /​var/​lib/​mysql /​var/​lib/​mysql_bak +
-sudo mv /etc/mysql /​etc/​mysql_bak +
-sudo mkdir /etc/mysql /​etc/​mysql/​conf.d +
-sudo apt clean</​code>​ +
-Vous pouvez ensuite choisir d'​installer ​[[:MySQL]] ou [[:MariaDB]] ​+
-<​code>​sudo apt install mysql-server</​code>​ +
-**__ou__** +
-<​code>​sudo apt install mariadb-server</​code>​ +
 ===== Voir aussi ===== ===== Voir aussi =====
  
-  * [[http://​www.it-connect.fr/​installer-un-serveur-lamp-linux-apache-mysql-php/​|Tutoriel ​Mise en place d'un serveur LAMP sur IT-Connect ​]] **(fr)** +  * [[:apache2|Apache]] 
-  * [[xampp]] Une version de LAMP simplifiée,​ servant pour le développement (seulement).+  * [[:PHP]] 
 +  ​[[:MySQL]] 
 +  * [[:MariaDB]]
  
 //​Contributeurs : [[utilisateurs:​krodelabestiole]],​ [[utilisateurs:​oxossi]],​ [[utilisateurs:​albanmartel]],​ [[utilisateurs:​harren]].//​ //​Contributeurs : [[utilisateurs:​krodelabestiole]],​ [[utilisateurs:​oxossi]],​ [[utilisateurs:​albanmartel]],​ [[utilisateurs:​harren]].//​
  • lamp.1531465244.txt.gz
  • Dernière modification: Le 13/07/2018, 09:00
  • par krodelabestiole