Différences

Ci-dessous, les différences entre deux révisions de la page.

Lien vers cette vue comparative

Les deux révisions précédentes Révision précédente
Prochaine révision
Révision précédente
digikam [Le 19/03/2018, 11:05]
L'Africain lien vers muon
digikam [Le 04/03/2019, 10:00] (Version actuelle)
82.241.84.32 [Installer la dernière version]
Ligne 1: Ligne 1:
-{{tag>Xenial ​gestionnaire_de_photos photo}}+{{tag>Bionic ​gestionnaire_de_photos photo}}
 ---- ----
 ====== digiKam ====== ====== digiKam ======
Ligne 7: Ligne 7:
 {{ http://​lh5.googleusercontent.com/​-ZQoHDqhopcw/​UkNZO8KNe8I/​AAAAAAAABeU/​Tqzod0tekSo/​w1002-h564-no/​digikamWindows3.4.0.png?​500 }} {{ http://​lh5.googleusercontent.com/​-ZQoHDqhopcw/​UkNZO8KNe8I/​AAAAAAAABeU/​Tqzod0tekSo/​w1002-h564-no/​digikamWindows3.4.0.png?​500 }}
  
-===== Pré-requis ===== 
- 
-  * Disposer des [[:​sudo|droits d'​administration]]. 
-  * Disposer d'une connexion à Internet configurée et activée. 
  
 =====Installation===== =====Installation=====
  
-Il suffit d'​[[:​tutoriel:​comment_installer_un_paquet|installer le paquet]] **[[apt>​digikam]]** et si vous souhaitez avoir la dcumentation ​[[:​tutoriel:​comment_installer_un_paquet|installez encore le paquet]] **[[apt>​digikam-doc]]**.+Il suffit d'​[[:​tutoriel:​comment_installer_un_paquet|installer le paquet]] **[[apt>​digikam]]** et si vous souhaitez avoir la documentation ​[[:​tutoriel:​comment_installer_un_paquet|installez encore le paquet]] **[[apt>​digikam-doc]]**.
  
 Un paquet complémentaire est nécessaire si vous souhaitez bénéficier des outils de modifications des photos et d'​édition des métadonnées (EXIF, IPTC...) **[[apt>​kipi-plugins]]** ([[http://​extragear.kde.org/​apps/​kipi/​|Site]]). Un paquet complémentaire est nécessaire si vous souhaitez bénéficier des outils de modifications des photos et d'​édition des métadonnées (EXIF, IPTC...) **[[apt>​kipi-plugins]]** ([[http://​extragear.kde.org/​apps/​kipi/​|Site]]).
  
 +====AppImage====
 +Vous trouverez [[https://​www.digikam.org/​download/​|ici]] l'​AppImage de Digikam.
 ==== Installer sous Ubuntu en limitant les dépendances KDE ==== ==== Installer sous Ubuntu en limitant les dépendances KDE ====
  
Ligne 31: Ligne 29:
 Ou bien en une ligne de commande: <​code>​sudo apt-get install --no-install-recommends digikam</​code>​ et si vous souhaitez installer les plugins : <​code>​sudo apt-get install --no-install-recommends kipi-plugins</​code>​ Ou bien en une ligne de commande: <​code>​sudo apt-get install --no-install-recommends digikam</​code>​ et si vous souhaitez installer les plugins : <​code>​sudo apt-get install --no-install-recommends kipi-plugins</​code>​
  
-Par contre sans les dépendances KDE, les thèmes de Digikam ne seront pas disponibles. Si vous désirez néanmoins pouvoir changer de thème, il suffit d'​[[:​tutoriel:​comment_installer_un_paquet|installer le paquet]] **[[apt>​kde-workspace-data]]**. +
-  ​+
 ==== Installer la dernière version ==== ==== Installer la dernière version ====
 <note important>​Pour une mise à jour depuis une précédente version de digiKam, il est conseillé de désinstaller l'​installation existante, afin de limiter les problèmes de dépendances. Il est également préférable de supprimer les fichiers ''​thumbnails-digikam.db''​ et ''​digikam4.db''​ ainsi que de sauvegarder vos "​TAG"​ sur vos images à partir de votre ancienne version Digikam avant de supprimer ces deux fichiers. <note important>​Pour une mise à jour depuis une précédente version de digiKam, il est conseillé de désinstaller l'​installation existante, afin de limiter les problèmes de dépendances. Il est également préférable de supprimer les fichiers ''​thumbnails-digikam.db''​ et ''​digikam4.db''​ ainsi que de sauvegarder vos "​TAG"​ sur vos images à partir de votre ancienne version Digikam avant de supprimer ces deux fichiers.
 </​note>​ </​note>​
 +<note important>​Philip Johnsson (aka Philip5) ne propose plus de paquets depuis Artful. Dernière version disponible pour Zeisty : Digikam 5.6.0.</​note>​
 Pour avoir la dernière version de digiKam: Pour avoir la dernière version de digiKam:
   * [[:​ppa#​ajout_d_un_ppa_a_vos_sources_logicielles|Ajoutez les PPAs]] **ppa:​philip5/​extra**((http://​ppa.launchpad.net/​philip5/​extra/​ubuntu/​)) (Ubuntu) ou **ppa:​philip5/​kubuntu-backports**((http://​ppa.launchpad.net/​philip5/​kubuntu-backports/​ubuntu/​)) (Kubuntu) dans vos sources de logiciels.   * [[:​ppa#​ajout_d_un_ppa_a_vos_sources_logicielles|Ajoutez les PPAs]] **ppa:​philip5/​extra**((http://​ppa.launchpad.net/​philip5/​extra/​ubuntu/​)) (Ubuntu) ou **ppa:​philip5/​kubuntu-backports**((http://​ppa.launchpad.net/​philip5/​kubuntu-backports/​ubuntu/​)) (Kubuntu) dans vos sources de logiciels.
Ligne 44: Ligne 42:
 =====Configuration===== =====Configuration=====
 <note important>​Depuis la version d'​ubuntu 16.04, la géolocalisation des photos ne marche plus dans Digikam4. Installer Digikam5 si vous utilisez cette fonctionnalité. <note important>​Depuis la version d'​ubuntu 16.04, la géolocalisation des photos ne marche plus dans Digikam4. Installer Digikam5 si vous utilisez cette fonctionnalité.
-Un autre bug majeur dans la distrib 17.04 : [[https://​bugs.kde.org/​show_bug.cgi?​id=378873]] ​ +Un autre [[https://​bugs.kde.org/​show_bug.cgi?​id=378873|bug]] majeur dans la distrib 17.04.</​note>​
-</​note>​+
 ==== Mettre Digikam en français sous Ubuntu ==== ==== Mettre Digikam en français sous Ubuntu ====
  
Ligne 76: Ligne 73:
 ==== Reconnaissance faciale / de visages ==== ==== Reconnaissance faciale / de visages ====
 La reconnaissance faciale fonctionne correctement,​ mais pas la détection des visages. Il faut donc indiquer manuellement le nom de la personne pour chaque étiquette. La reconnaissance faciale fonctionne correctement,​ mais pas la détection des visages. Il faut donc indiquer manuellement le nom de la personne pour chaque étiquette.
 +=====Problème connus===== 
 +====Digikam ne s'​ouvre plus après une migration de 16.04 à 18.04==== 
 +Dans le cas d'une mise à jour de Ubuntu 16.04 vers 18.04 par exemple, la version de Digikam (et de Kde) change de la version 4.x.x à la version 5.x.x. Si on lance la version 5.x.x dans 18.04, il y a une erreur qui s'​affiche et on a l'​impression d'​avoir perdu toutes les photos et les tags associés. Il n'en est rien. Voici la procédure pour le faire marcher : 
 +  - fermer Digikam 5.x.x 
 +  - faire une copie de sauvegarde des fichiers de base de données de Digikam appelés digikam4.db et thumbnails-digikam.db. Normalement ils sont dans ~/Images. 
 +  - copier tous les fichiers et répertoires suivants (([[https://​bugs.kde.org/​show_bug.cgi?​id=364258#​c7|source]] et [[https://​bugs.kde.org/​show_bug.cgi?​id=364258#​c8|ici]] par l'​auteur de Digikam Gilles Caulier)):​ 
 +    * Dans **~/​.kde4/​share/​config/​** (ou ~/​.kde/​share/​config/​),​ déplacer les fichiers ''​digikamrc,​ digikam_tagsmanagerrc,​ kipipluginsrc,​ kipirc, showfotorc''​ vers le dossier **~/​.config/​** 
 +    * Déplacer tous les fichiers du dossier **~/​.kde4/​share/​apps/​digikam/​** vers **~/​.local/​share/​apps/​digikam/​** 
 +  - Démarrer Digikam 5.x.x.
 ===== Désinstallation ===== ===== Désinstallation =====
  
  • digikam.1521453934.txt.gz
  • Dernière modification: Le 19/03/2018, 11:05
  • par L'Africain