Différences

Ci-dessous, les différences entre deux révisions de la page.

Lien vers cette vue comparative

Les deux révisions précédentes Révision précédente
ant [Le 06/06/2017, 05:19]
41.82.177.75 [ant]
ant [Le 06/06/2017, 11:40] (Version actuelle)
Roschan
Ligne 1: Ligne 1:
-{{tag>Precise ​programmation}}+{{tag>Trusty ​programmation}}
  
 ====== ant ====== ====== ant ======
  
-//**ant**// est une bibliothèque Java et un programme en ligne de commande (écrit en JAVA) qui permet de lancer et contrôler des processus. L'​emploi le plus connu est de créer un "​exécutable"​ Java à partir de source et de bibliothèques (mais il peut être utilisé dans d'​autres buts).+//**ant**// est une bibliothèque Java et un programme en ligne de commande (écrit en Java) qui permet de lancer et contrôler des processus. L'​emploi le plus connu est de créer un "​exécutable"​ Java à partir de source et de bibliothèques (mais il peut être utilisé dans d'​autres buts).
  
-Il est l'​équivalent de la commande //make// des langages C / C++. +Il est l'​équivalent de la commande //make// des langages C / C++. \\ 
-À noter que désormais, la commande ​//​Maven// ​(qui a été créé pour gérer les problèmes de dépendances de bibliothèques qui ont empoisonné //ant// pour les gros projets) est préférée à //ant//.+À noter que désormais, la commande ​[[maven]] ​(qui a été créé pour gérer les problèmes de dépendances de bibliothèques qui ont empoisonné //ant// pour les gros projets) est préférée à //ant//.
  
 Pour fonctionner,​ //ant// nécessite au minimum le runtime Java (JRE). De plus, et ce afin d'​obtenir un maximum de possibilités,​ il est préférable d'​installer le JDK. Pour fonctionner,​ //ant// nécessite au minimum le runtime Java (JRE). De plus, et ce afin d'​obtenir un maximum de possibilités,​ il est préférable d'​installer le JDK.
Ligne 13: Ligne 13:
 ===== Installation classique ===== ===== Installation classique =====
  
-//ant// fait partie de la bibliothèque de logiciels de //Ubuntu//, il faut simplement [[:​tutoriel:​comment_installer_un_paquet|installer le paquet]] **[[apt>​ant]]** +Il faut simplement [[:​tutoriel:​comment_installer_un_paquet|installer le paquet]] **[[apt>​ant]]**
- +
-A noter, que la version proposée par //Precise// est 1.8.2 alors que la dernière version (en Janvier 2014) est 1.9.3. Pour un développeur,​ il peut être intéressant d'​utiliser la dernière version, en téléchargeant et en installant //ant// depuis le [[http://​ant.apache.org|Apache.org site officiel]].+
  
 ===== Installation manuelle ===== ===== Installation manuelle =====
Ligne 35: Ligne 33:
  
 Pour que les modifications de variables d'​environnement dans votre fichier ''​.profile''​ soient "​actives",​ il est nécessaire de se reconnecter (ou bien de //sourcer// le fichier ''​.profile''​ dans un terminal, mais ceci ne sera actif que dans ce terminal). Pour que les modifications de variables d'​environnement dans votre fichier ''​.profile''​ soient "​actives",​ il est nécessaire de se reconnecter (ou bien de //sourcer// le fichier ''​.profile''​ dans un terminal, mais ceci ne sera actif que dans ce terminal).
- 
  
 =====  Voir aussi  ===== =====  Voir aussi  =====
  • ant.txt
  • Dernière modification: Le 06/06/2017, 11:40
  • par Roschan